IP Packet Forwarding Performance Comparison of the FD.io VPP and the Linux Kernel

There are numerous free software solutions for IPv4 or IPv6 packet forwarding. The Fast Data Project / Vector Packet Processing (FD.io VPP) is a novel and prominent solution. This paper investigates its performance and scalability compared to that of the Linux kernel. The investigation was conducted in accordance with the requirements outlined in the relevant Request for Comments (RFC) documents (RFC 2544, RFC 4814, and RFC 5180) using the siitperf measurement software. Two different test environments were used to eliminate the potential hardwarespecific side effects and to gain insight into the performance and scalability of the IPv4 and IPv6 packet forwarding capability of the two investigated solutions. It was found that FD.io VPP outperformed the Linux kernel by approximately an order of magnitude. The configuration of FD.io VPP, along with the details of the measurements, are provided, and the results are presented and analyzed in the paper.

Publication Details

Journal
Repository of the Academy's Library (Library of the Hungarian Academy of Sciences)
Published
2025-01-01
Primary Topic
Geochemistry and Geologic Mapping
Type
article
Field-Weighted Citation Impact
0.00
Controls
|||
ALL TIME
JAN
FEB
MAR
APR
MAY
JUN
JUL
AUG
SEP
OCT
article

IP Packet Forwarding Performance Comparison of the FD.io VPP and the Linux Kernel

Repository of the Academy's Library (Library of the Hungarian Academy of Sciences)
Geochemistry and Geologic Mapping
article

IP Packet Forwarding Performance Comparison of the FD.io VPP and the Linux Kernel

article en

Abstract

There are numerous free software solutions for IPv4 or IPv6 packet forwarding. The Fast Data Project / Vector Packet Processing (FD.io VPP) is a novel and prominent solution. This paper investigates its performance and scalability compared to that of the Linux kernel. The investigation was conducted in accordance with the requirements outlined in the relevant Request for Comments (RFC) documents (RFC 2544, RFC 4814, and RFC 5180) using the siitperf measurement software. Two different test environments were used to eliminate the potential hardwarespecific side effects and to gain insight into the performance and scalability of the IPv4 and IPv6 packet forwarding capability of the two investigated solutions. It was found that FD.io VPP outperformed the Linux kernel by approximately an order of magnitude. The configuration of FD.io VPP, along with the details of the measurements, are provided, and the results are presented and analyzed in the paper.

Repository of the Academy's Library (Library of the Hungarian Academy of Sciences)
Openalex Percentile: Top 72%
Geochemistry and Geologic Mapping
AI Navigator

Ask Laika to Summarize, Analyze, and Connect papers live on the map.

Summarize Papers & Methodologies

Extract key findings, datasets, and comparative methods across publications.

Benchmark Rankings & Visual Analytics

Rank top research institutions, authors, funders, topics, and journals by Field-Weighted Citation Impact (FWCI) and paper volume with instant charts.

Connect Distant Disciplines

Bridge topological clusters on the map to find hidden collaborative intersections.