Equivalence and difference of the dual device under test setup and the single device under test setup of RFC 8219

Summary RFC 8219 has defined a comprehensive benchmarking methodology for the IPv6 transition technologies. It recommends two kinds of measurement setups: The dual device under test (DUT) setup facilitates the benchmarking of the customer edge (CE) and provider edge (PE) devices together using a legacy RFC 2544 or RFC 5180 Network Performance Tester, whereas the single DUT setup requires a separate technology‐specific tester for the benchmarking of each device. As such, special‐purpose testers do not exist for the vast majority of the IPv6 transition technologies; the only viable solution can be the usage of the dual DUT setup. In this paper, we investigate if the two kinds of measurement setups provide the same or different results; moreover, we examine how the single DUT measurement results can be estimated from the dual DUT measurement results. To that end, we make theoretical considerations and also perform IPv4 packet forwarding and stateless IP/ICMP translation (SIIT) measurements using both measurement setups and analyze the results of the throughput and latency measurements. It was found that the throughput results of the dual DUT setup could approximate well those of the single DUT setup and their differences followed the predictions of our theoretical considerations. However, the latency results did not always follow the theoretical expectations.

Authors

Institutions

Publication Details

Journal
International Journal of Communication Systems
Published
2024-09-23
DOI
https://doi.org/10.1002/dac.5982
Citations
1
Primary Topic
Green IT and Sustainability
Type
article
Field-Weighted Citation Impact
0.21
Controls
|||
ALL TIME
JAN
FEB
MAR
APR
MAY
JUN
JUL
AUG
SEP
OCT
article

Equivalence and difference of the dual device under test setup and the single device under test setup of RFC 8219

Szabolcs Szilágyi, Gábor Lencse
1 citations
International Journal of Communication Systems
Green IT and Sustainability
0.21
article

Equivalence and difference of the dual device under test setup and the single device under test setup of RFC 8219

Szabolcs Szilágyi, Gábor Lencse
article en
1 citations

Abstract

Summary RFC 8219 has defined a comprehensive benchmarking methodology for the IPv6 transition technologies. It recommends two kinds of measurement setups: The dual device under test (DUT) setup facilitates the benchmarking of the customer edge (CE) and provider edge (PE) devices together using a legacy RFC 2544 or RFC 5180 Network Performance Tester, whereas the single DUT setup requires a separate technology‐specific tester for the benchmarking of each device. As such, special‐purpose testers do not exist for the vast majority of the IPv6 transition technologies; the only viable solution can be the usage of the dual DUT setup. In this paper, we investigate if the two kinds of measurement setups provide the same or different results; moreover, we examine how the single DUT measurement results can be estimated from the dual DUT measurement results. To that end, we make theoretical considerations and also perform IPv4 packet forwarding and stateless IP/ICMP translation (SIIT) measurements using both measurement setups and analyze the results of the throughput and latency measurements. It was found that the throughput results of the dual DUT setup could approximate well those of the single DUT setup and their differences followed the predictions of our theoretical considerations. However, the latency results did not always follow the theoretical expectations.

International Journal of Communication SystemsVol. 38(3)
University of Debrecen (HU), Széchenyi István University (HU)
Openalex Percentile: Top 48%
Green IT and Sustainability
0.21
AI Navigator

Ask Laika to Summarize, Analyze, and Connect papers live on the map.

Summarize Papers & Methodologies

Extract key findings, datasets, and comparative methods across publications.

Benchmark Rankings & Visual Analytics

Rank top research institutions, authors, funders, topics, and journals by Field-Weighted Citation Impact (FWCI) and paper volume with instant charts.

Connect Distant Disciplines

Bridge topological clusters on the map to find hidden collaborative intersections.